SMP MOTORSPORTS

Enthusiast Car Forum

Navigation

July 2018

MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Calendar Calendar

Gallery



    I have a problem!!

    Share
    avatar
    Kung Fu Sifu

    Number of posts : 34
    Points : 3511
    Reputation : 0
    Registration date : 2009-03-08
    Location : Under The Sky!!!

    I have a problem!!

    Post  Kung Fu Sifu on Sat Mar 21, 2009 7:11 pm

    Well, i took my car to be washed earlier today and everything went well. But when i got home i noticed on the polished lip of my Ruff r281 rims, there were blue water marks all dried up over the lip. After i tried to clean them with some armor all wheel cleaner, they never wiped off. Can anyone tell me how to fix this problem. Or has anyone had one like it?
    avatar
    Supa Ninja
    Admin
    Admin

    Number of posts : 267
    Points : 4085
    Reputation : 12
    Registration date : 2009-03-03
    Age : 42
    Location : Your moms

    Re: I have a problem!!

    Post  Supa Ninja on Sat Mar 21, 2009 7:16 pm

    most likely your lips are clear coated, so try some WD40. that should do the trick. Now if your lips are not clear coated neverdull would be your ticket. Warning warning warning never use neverdull on painted surfaces, its a badass paint remover.
    avatar
    jesse
    Admin
    Admin

    Number of posts : 299
    Points : 4098
    Reputation : 15
    Registration date : 2009-03-03

    Re: I have a problem!!

    Post  jesse on Sat Mar 21, 2009 7:25 pm

    First of all never use Armor All. It sucks. Try using aluminum polish cleaner. Pepboys has it
    avatar
    Supa Ninja
    Admin
    Admin

    Number of posts : 267
    Points : 4085
    Reputation : 12
    Registration date : 2009-03-03
    Age : 42
    Location : Your moms

    Re: I have a problem!!

    Post  Supa Ninja on Sat Mar 21, 2009 8:16 pm

    i wouldn't use any metal polish if the lips are clear coated.

    wd40 is a solvent but it won't hurt paint, it will make it nice and shiny too
    avatar
    jesse
    Admin
    Admin

    Number of posts : 299
    Points : 4098
    Reputation : 15
    Registration date : 2009-03-03

    Re: I have a problem!!

    Post  jesse on Sun Mar 22, 2009 1:05 am

    2 Thumbs down on that idea
    avatar
    Supa Ninja
    Admin
    Admin

    Number of posts : 267
    Points : 4085
    Reputation : 12
    Registration date : 2009-03-03
    Age : 42
    Location : Your moms

    Re: I have a problem!!

    Post  Supa Ninja on Sun Mar 22, 2009 1:19 am

    jesse wrote:2 Thumbs up on that idea, two thumbs down for it working

    fixed
    avatar
    jesse
    Admin
    Admin

    Number of posts : 299
    Points : 4098
    Reputation : 15
    Registration date : 2009-03-03

    Re: I have a problem!!

    Post  jesse on Wed Mar 25, 2009 4:19 pm

    Did the spots ever go away
    avatar
    Kung Fu Sifu

    Number of posts : 34
    Points : 3511
    Reputation : 0
    Registration date : 2009-03-08
    Location : Under The Sky!!!

    Re: I have a problem!!

    Post  Kung Fu Sifu on Sat Mar 28, 2009 3:20 pm

    Well, I havent had time to do it but im going to try it later on today. Hopefully if it stops raining. Is it possible that if i leave the spots on therte for a long time that they will bake into the metal and stay there?
    avatar
    jesse
    Admin
    Admin

    Number of posts : 299
    Points : 4098
    Reputation : 15
    Registration date : 2009-03-03

    Re: I have a problem!!

    Post  jesse on Sat Mar 28, 2009 3:52 pm

    The longer you leave them the more chance of it leaving a stain there.
    avatar
    Kung Fu Sifu

    Number of posts : 34
    Points : 3511
    Reputation : 0
    Registration date : 2009-03-08
    Location : Under The Sky!!!

    Re: I have a problem!!

    Post  Kung Fu Sifu on Sat Mar 28, 2009 4:50 pm

    CRAP!!!!
    avatar
    Kung Fu Sifu

    Number of posts : 34
    Points : 3511
    Reputation : 0
    Registration date : 2009-03-08
    Location : Under The Sky!!!

    Re: I have a problem!!

    Post  Kung Fu Sifu on Sun Mar 29, 2009 5:42 pm

    I used boiling hot water and it didn't work so I used some Mothers Silver polish and the lips look good as new! Thanks for the tips
    avatar
    Huggy Bear
    Mod
    Mod

    Number of posts : 93
    Points : 3666
    Reputation : 6
    Registration date : 2009-03-05
    Age : 35
    Location : In Jessica Alba's Nightmares

    Re: I have a problem!!

    Post  Huggy Bear on Tue Jun 02, 2009 5:17 pm

    Next time i'll lick them for you if you give me a dollar.

    Sponsored content

    Re: I have a problem!!

    Post  Sponsored content


      Current date/time is Wed Jul 18, 2018 6:01 am